Service disruption affecting Training functionality for some customers

Incident Report for Mitti by SafetyCulture

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 12:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2026 - 11:04 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 14, 2026 - 10:43 UTC

Investigating

We are aware of an issue impacting the functionality of the Training feature for some customers.

Our engineering teams are currently investigating, and we will provide an update as soon as one is available.
Posted Sep 14, 2026 - 10:22 UTC
This incident affected: Mitti by SafetyCulture (Training).