Delayed email notifications

Incident Report for Mitti by SafetyCulture

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 19:10 UTC

Monitoring

A fix has been deployed and we will continue to monitor this closely.
Posted Sep 04, 2026 - 16:26 UTC

Investigating

We are currently aware of an issue impacting email notifications. Our engineering teams are investigating, and we will provide updates as soon as they are available.
Posted Sep 04, 2026 - 12:58 UTC
This incident affected: Mitti by SafetyCulture (Web Platform).